Thursday, February 01, 2007

Episode 2: Sound

The continuing adventures of migrating from MS Windows to Ubuntu Linux. After a few days of using Ubuntu on my office desktop PC, after installing a few apps and browser plugins, I've got some issues with sounds.

With Windows, the opening "jingle" came out of the speakers when the machine booted, and various sounds played when different things happened. With Windows, if I plugged in my USB headset, no sounds went to the speakers. They went to the headset instead. When I unplugged my headset, sounds played on the speakers again. And this worked even if I plugged and unplugged my headset with the computer running. Windows figured it out. But not Ubuntu.

Here's the good news. Ubuntu successfully identified the make and model number of both my sound card and my USB headset. The issues I am having are probably driver related problems. So, you may not have the same experience I am having, if you have different hardware.
  • Without the headset plugged in, I do not hear the opening jingle when the machine boots. But, otherwise the sounds work fine, coming out of the speakers.
    • One thing I discovered through trial and error is that I didn't hear any sounds from the speakers until I had the volume control on the speakers turned up loud AND the Ubuntu sound widget volume turned up also.
  • With the headset, I do hear the opening boot-up jingle and all the sounds through the headset and not the speakers.
    • Except, there is a sound application called Gtick (a metronome) that I installed that only plays through the speakers and not the headset. In fact, I can run Gtick and hear it ticking over the speakers and run Rhythmbox (music player) and hear it playing music at the same time only in the headset. Weird.
    • Booting the computer without the headset plugged in and then plugging in the headset results in message popping up telling a new audio playback device has been detected. I can click a link in this message and go to Sound Preferences, where I see that the headset is now listed as the "Default sound card." However, all the sounds keep coming out of the speakers. Only if I reboot with the headset plugged in does the headset work.

Sound issues are a bit of a nuisance, since I now have to reboot whenever I want to listen to something over the headset. However, this is not so bad that is going to drive me away from Ubuntu.

Episodes: 1, 2, 3, 4, 5, 6.

No comments: